FlytrapCare Carnivorous Plant Forums

Sponsored by FlytrapStore.com

Ask questions about how to grow and care for Venus Flytraps

Moderator: Matt

By VFTNoob
Posts:  36
Joined:  Tue Apr 28, 2020 3:53 pm
#366155
Hi all,

I have 2 plants in the pictures below that I grow outside in zone 9 year round. The first plant a weird collection of spots on a new growth point. They are in other spots on the plant but less clustered. Looks like there are a few on another younger growth point.

The 2nd picture is of a few of my plant's stems that are turning black before the traps do. Is this normal? Usually the trap part of the leaf is the first to die and the stem kind of hangs out until the plant decides to get rid of it.

I have Scotts DiseaseEx and Bioadvanced 3 in 1 at the ready if these are fungal infections. If this is pest damage, I have some stuff for that as well.

All help is greatly appreciated!

http://imgur.com/gallery/pYJcNgG
User avatar
By Matt
Location: 
Posts:  21524
Joined:  Mon Apr 21, 2008 11:28 pm
#366159
You have a very, very healthy-looking flytrap there!! I see nothing at all to worry about in the photo. The blackening spots look like some sort of trauma caused by insects or birds or squirrels or some other pest. Good growing! :D
VFTNoob liked this
By VFTNoob
Posts:  36
Joined:  Tue Apr 28, 2020 3:53 pm
#366164
Thanks Matt! As usual, just me overthinking things that come with growing flytraps outdoors. Did you see the new growth with the spots? Any idea what that could be?
User avatar
By Matt
Location: 
Posts:  21524
Joined:  Mon Apr 21, 2008 11:28 pm
#366177
@VFTNoob, I just took another look and it could be mite damage. Hard to say from the photo because it isn't a full-blown mite outbreak, but the damage on the new trap does look a bit like mite damage. I'd suggest keeping a close eye on it, checking it daily, and taking action as necessary. I wouldn't do anything at the moment though if it were my plant :D
VFTNoob liked this
By VFTNoob
Posts:  36
Joined:  Tue Apr 28, 2020 3:53 pm
#366185
Appreciate it, I'll continue to observe. I have avid miticide and orthene on hand just incase
By VFTNoob
Posts:  36
Joined:  Tue Apr 28, 2020 3:53 pm
#367290
Update: I do believe some sort of mite was attacking my plants. I sprayed all my plants with avid about 3 times over the last 2 weeks. New growth from the SD Kronos is looking healthy with no spots or marks. Got a loupe just to be sure next time.

In answer to your specific questions, it will be O[…]

I got another Mars Hydro light and attached it to […]

nike femme

Voici un nike femme aperçu d'un év[…]

womens nike trainers

Show some respect womens nike trainers when an O[…]

Gibberellic Acid

PPM of that GA3 is 1100 to 1200. Just remembered t[…]

Highland Nep help

Those D. Alba look neat. I'm starting to want some[…]

I think those plants grow so slow that once it g[…]

Double pitcher Cephalotus

Interesting stuff. I feel personally that the pitc[…]

Support the community - Shop at FlytrapStore.com!