FlytrapCare Carnivorous Plant Forums

Sponsored by FlytrapStore.com

Discuss any carnivorous plant that doesn't fit in the above categories here or general chat about carnivorous plants

Moderator: Matt

By Tyrael
Posts:  5
Joined:  Fri May 22, 2020 1:38 pm
#369280
Hello
I have set up a "tank" with Utricularia pubescens some month ago in 60/40 blond peat/sand, lightning TerraLed 50W (actually 7 hours/day).
They have grown and developped well, but since some weeks several plants looks dried/brown. I am not sure what this is. Maybe normal, or not ...
Do you have any idea what could be the cause? I thought it could be a lightning issue but if I'm not wrong Utricularia pubescens like high luminosity or maybe watering ... to be honest I don't so I am wainting some tips :D

Thank you in advance!
P.S: I am not a native English speaker, sorry.

Image
Image
Image
Image
Image
Image
Image
By hungry carnivores
Posts:  556
Joined:  Sun Apr 05, 2020 7:31 am
#369284
Hey!

No need to worry about your english, it's fine. This is a multinational forum, so we welcome everybody.

That looks like old growth dying. Maybe increase your light to 12 hours, but apart from that, the plant looks healthy and there looks to be new growth.

Best,
HC
By Tyrael
Posts:  5
Joined:  Fri May 22, 2020 1:38 pm
#373093
Hi,

I still have this "problem", it's not really developing too much, but not disappearing aswell.... any new ideas on what this could be?
Some people told me it could be mushroom or odium.
What do you think?

Thank you!

Below some actual visual update

Image

Image

Image

Image
By TrapHappy
#373109
Wow!!! Pubescens is my favorite Utricularia, you have a beautiful specimen! It looks like sunburn to me, if so then that’s an easy fix :) I sent you a pm
By twitcher
Posts:  630
Joined:  Sat Aug 25, 2018 5:56 am
#373140
I am really impressed by how well your pubescens are doing. Mine never did that well, remaining sparse. I think they need a lot of water, but yours are doing better than mine, so that might not be correct. They do seem to like to "run" in a straight line for me, so I think a larger container, which you have, is helpful in getting a good colony. Thanks for the pictures.
By Huntsmanshorn
Posts:  614
Joined:  Wed Sep 03, 2014 6:32 am
#373182
This looks like it could be colony collapse which usually happens when the Urtic colony runs out of room. Unfortunately there is not much that can be done, sometimes things will get better but frequently they do not so, if I were you, I would take a nice big, clean plug and start a new colony.
I have a problem and I need help.

I'm starting to believe you could dump maxsea powd[…]

Drosera regia flowering soon!

Whats the trick to pollinating these? I had flow[…]

Early Christmas

Nice. I miss my tank. I don't miss the upkeep, t[…]

I'll certainly see about getting some Avid from y[…]

Sase sent! Sorry it took so long!

Hear! Hear!

May Flowers - May Photo Contest

An absolutely massive flower on Drosera hamiltonii[…]

Growing CPs under a tree.

Flytraps and sarracenia can generally handle the h[…]

Support the community - Shop at FlytrapStore.com!