FlytrapCare Carnivorous Plant Forums

Sponsored by FlytrapStore.com

Discuss water requirements, "soil" (growing media) and suitable planting containers

Moderator: Matt

By laeschlein
Posts:  3
Joined:  Sun Aug 14, 2022 4:02 pm
#418229
I've noticed a 'carpet' of some kind of fungus growing over half of the surface of my bog garden (VFTs & drosera) as well as on top of the media in my nepenther pot - doesn't seem to be growing on any of the plants themselves, and I haven't noticed any obvious growth issues (yet, anyway). Google isn't helping in terms of identification.

Just wondering if anyone has had this before/if I should attempt to get rid of it. Thanks for any advice!
Attachments:
20220814_170353.jpg
20220814_170353.jpg (5.8 MiB) Viewed 870 times
20220814_170402.jpg
20220814_170402.jpg (6.83 MiB) Viewed 870 times
20220814_170411.jpg
20220814_170411.jpg (6.44 MiB) Viewed 870 times
20220814_170423.jpg
20220814_170423.jpg (5.95 MiB) Viewed 870 times
User avatar
By MaxVft
Location: 
Posts:  1212
Joined:  Sat May 08, 2021 4:17 am
#418232
I’m no expert, but it looks to me like your moss is flowering spores.
User avatar
By ChefDean
Location: 
Posts:  6719
Joined:  Tue Sep 18, 2018 12:44 am
#418243
I saw something similar in a FB post the other day, and the general consensus was slime mold. Not necessarily detrimental, but not beneficial either.
Keep an eye on it to make sure it doesn't overgrow your plants, and you should be fine.
Unique G16 x Self Seedling?

Nope, G16 OP Yea, I know. I was just saying wh[…]

Show Your Aquarium

My 65g saltwater tank, almost as expensive as ca[…]

Not AGAIN!

Do they sell and ship to Greece? If not, can I f[…]

Been really busy this summer

Happy for his youth then lol

I'm going to buy a 4-cubic-foot bag of perlite. I […]

So I'm looking at nepenthesaroundthehouse.com (as […]

SASE is in the mail along with a few different typ[…]

Support the community - Shop at FlytrapStore.com!