FlytrapCare Carnivorous Plant Forums

Sponsored by FlytrapStore.com

Discuss Nepenthes plant care here

Moderator: Matt

By dtyburgess
Posts:  11
Joined:  Mon Nov 26, 2018 11:40 am
#344769
Can anyone tell me what is happening to this plant????
Everything was going great until 3 to 4 months ago when it started to go into serious decline.
Temp is 23 cel day amd 15-17 night,
45 sec misting in the morn and 3 x 10 sec mist through the day (deminiralised water) Humidity is around 80%
Half strength orchid fertilizer once a month.
Any ideas what could be happening?
I really don’t want to lose this guy, please help!!

Image


Sent from my iPhone using Tapatalk
User avatar
By Fiolop
Posts:  52
Joined:  Sat Jan 12, 2019 9:44 pm
#344773
I am no expert but i think you're keeping it too cold,albomarginata is a lowlander and those are highland-ish conditions.but different plants may vary in temperature tolerance

Sent from my SM-A310F using Tapatalk
By tzestan
Posts:  358
Joined:  Thu Jul 09, 2009 3:08 pm
#344774
Albomarginata, nepenthes generally, cannot tolerate high salinity. Half strength orchid fertilizer sounds too much. Assuming it was poured at the root zone, how much in volume, and for how long before the remains was flushed out with water?

Likely the roots are damaged. If really wants to experiment with fertilizer, it is better to start feeding into pitcher to get an idea of how much is too much. This destroys a pitcher instead of the whole plant.
By tanqueray
Posts:  16
Joined:  Mon Aug 05, 2019 7:17 am
#344838
As already states, temps are probably a bit low (although I wouldn’t expect them to have this effect on your plant). You should only consider feeding once everything else is right, temperature, light, humidity etc. If these aren’t right, the plant not only will struggle to utilise the fertiliser, but it may also cause damage, as it appears to have done here.
I’d suggest flushing the roots out thoroughly with water, and the leaves. Then put it in a stable place, leave it there, don’t fertilise it further and pray.
By dtyburgess
Posts:  11
Joined:  Mon Nov 26, 2018 11:40 am
#344840
Thanks all, i pulled the plant out today and the root ball was black and non exsistant
Ive pulled it out, flushed the roots and repotted it and moved it to another tank.
Heres hoping im not too late


Sent from my iPhone using Tapatalk
By dtyburgess
Posts:  11
Joined:  Mon Nov 26, 2018 11:40 am
#344869
PlanT640847401 wrote:Same thing happened to my plant

Once it starts to die it dies faster and faster each day
Image
Try to flush any salt out
Ah crap. Did you end up saving yours??


Sent from my iPhone using Tapatalk
P. Lutea Leaf Pullings

Hi Ben, I've been trying to work with the US warm[…]

Thanks alot everyone @Shadowtski I got it already[…]

Trade for Pings

Thanks guys for the interest. I have everything m[…]

Another Pest ID

We are specialising in height adjustable kids desk[…]

Received SASE today. Thank you

New VFT owner in Virginia

Sadly the KMS I ordered did not like the journey i[…]

Tiny white bugs on vft

I haven’t seen any more deformed traps so I […]

Here's an update on the flower: IMG_20200711_193[…]

Support the community - Shop at FlytrapStore.com!