FlytrapCare Carnivorous Plant Forums

Sponsored by FlytrapStore.com

Say hello and tell everyone a bit about yourself.

Moderator: Matt

By jhfox
Posts:  1
Joined:  Sun May 08, 2022 2:25 pm
#410357
Hello
At the end of last season and after my trap flowered I repotted my trap in a mix of Pertite and Pete moss. The trap is growing again however all the new little traps keep turning brown and appear to be dying. There is a abundance of new healthy traps growing.
Watering with distilled water.
I had the bottom 2" of the pot submerged in a fish/ plant pond. I have taken it out of the pond for now and the bottom of the pot is submerged in distilled water. Any ideas why the new traps keep dying?
Attachments:
20220508_075027.jpg
20220508_075027.jpg (3.26 MiB) Viewed 805 times
20220508_075021.jpg
20220508_075021.jpg (3.18 MiB) Viewed 805 times
20220508_073647.jpg
20220508_073647.jpg (3.54 MiB) Viewed 805 times
20220508_073652.jpg
20220508_073652.jpg (3.64 MiB) Viewed 805 times
User avatar
By Panman
Location: 
Posts:  3986
Joined:  Wed Mar 04, 2020 8:41 pm
#410386
Likely it was too wet. In a pot that size, you will only want about 1/2 inch of water in the tray and you will want to let the tray dry out between watering.
B. Pilbarana

I’m currently in search for more location […]

I recommend buying from @optique. That's where I o[…]

Some of my favorites

Some of my favorites that I bought late season las[…]

Please help me with mites

If you saw them move around they’re probably[…]

Sphagnum for sale!

Hey Adrien. Where is the moss from? harvest[…]

My first mystery box!

I need to buy peat and perlite next year. I have a[…]

I think I have mites....

Just watched this myself for my own protection aga[…]

Help! Worried about Venus Flytrap

I agree on getting rid of the black pot. I ended[…]

Support the community - Shop at FlytrapStore.com!